Subject: Re: Help enabling PCI ethernet card, tlp0
To: netbsd <>
From: Philip Brodd <>
List: netbsd-users
Date: 12/11/2002 19:39:28
--- Ceri Storey <> wrote:
> On Wed, Dec 11, 2002 at 06:55:01PM -0800, Philip Brodd wrote:
> > Here is the output of ifconfig -a.  This is after I have changed the
> interface
> > from "mc0" to "tlp0" in dhclient.conf and rebooted.
> > 
> > tlp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
> >         address: 00:00:94:cc:6c:7f
> >         media: Ethernet autoselect (none)
> >         status: no carrier
>           ^^^^^^^^^^^^^^^^^^
> I believe this is your problem :) I take it you're sure the cable's
> plugged in? You may beed to reseat it, on the card as well as the switch
> / whatever. 

Ha, this shows my attention to detail :^)  The cable does appear to be seated
snugly in both the card and the base station, however.  I also tried a few
other known good cables with the same result.  I'm left with three
possibilities.  How much sense do these make?

1) It's dhclient's fault.  It's clinging to the notion that I want to use the
mc0 interface.  Could this be cached somewhere I don't know about?  But this
doesn't fit with the "no carrier" in ifconfig's output.

2) It's the tlp driver's fault.  I'm not very qualified to ponder this one. 
Could it be broken in such a way that it doesn't recognize working hardware?

3) It's the card's fault.  I guess this seems the most likely, but is it weird
that NetBSD recognizes broken hardware?  I haven't yet tried the card in
another machine running a different OS.  This is a brand new card, but I guess
these things happen from time to time.

Take care,


Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.