Subject: PCI card mapping problems (was: Problem with Fritz!PCI)
To: None <>
From: Michael Kukat <>
List: netbsd-users
Date: 12/06/2002 08:47:52
Hello again,

On Thu, 5 Dec 2002, Michael Kukat wrote:
> i have a little problem using ISDN in NetBSD-1.6 release. First, i got a
> Fritz!PCI V2.0, which simply isn't supported in this release, i saw work in
> -current. So i got the "old" Fritz!PCI and tried this. But i get the error:
> ifpci0 at pci0 dev 14 function 0: Fritz!PCI card
> ifpci0: can't map card

So, after some nice dialogs with Hartin Husemann and some valuable hints from
him, and some experimenting by me, the problem is finally solved. As this seems
to be a more generic PCI problem, which can happen with differend cards also, i
want to post the very simple solution here, so the next one has more success
when google'ing for "can't map card".

The problem seems to be the PCI bus/bridge drivers not configuring the cards in
some cases (should they?). So the cards don't have any IRQs assigned, don't
want to map I/O or Memory and some other strange effects in pcictl-dumps.

The strange thing: Some cards (like the fxp0 EtherExpress card) are configured
correctly, and others (like Fritz!PCI, 3C905, Altera Flex thing, and even
onboard USB) aren't configured.

The solution: Check your BIOS settings and set "PnP aware OS" to "No".

So found on a newer ASUS board, but this might happen on other boards also.
Chipset: some VIA KT400 or so.


--     Home Powered by: (Net|Open|Free)BSD IRIX NonStop-UX
Solaris AIX HP-UX Tru64 MUNIX Ultrix VMS SINIX Dolphin_Unix OpenStep MacOS A/UX