Subject: Re: terminals under X 4.2.0 - problems with variables and setup
To: Lubos Vrbka <>
From: Greg A. Woods <>
List: netbsd-users
Date: 12/05/2002 19:19:37
[ On Thursday, December 5, 2002 at 20:08:49 (+0100), Lubos Vrbka wrote: ]
> Subject: Re: terminals under X 4.2.0 - problems with variables and setup
> it worked fine with netbsd-1.5 on i386, X11R6 version 4.0.1 and before it. i
> upgraded to netbsd-1.6, X11R6 4.2.0 few months ago and it worked no more. my
> colleague upgraded to 1.6 week ago and experienced the same "problem".

I don't know about separate Xfree86 distributions for NetBSD, nor even
for certain about the xterm in xsrc/xfree, but I do know that what's
been in /usr/xsrc has _always_ required '-ls' to make the shell started
by an xterm into a login shell.

> hope that the wrong information in the man (-e switch is incompatible
> with -ls;  xterm -ls -e ssh name works fine) will be removed...

Why would you expect '-ls' and '-e' to be compatible?  They really are not.

'-ls' causes, among other things IIRC, a '-' character to be prepended
to the argv[0] value of the shell process.  This is how the shell
figures out that it's supposed to be a login shell.  See sh(1):

          When first starting, the
     shell inspects argument 0, and if it begins with a dash `-', the shell is
     also considered a login shell.  This is normally done automatically by
     the system when the user first logs in.  A login shell first reads com-
     mands from the files /etc/profile and .profile if they exist.

'-e' on the other hand runs something other than a shell so whatever you
specify to run has to tell the ultimate shell to be a login shell.

I'm beginning to notice that you mentions '-e ssh' on occasion.  That's
probably your problem:  SSH    Not xterm.

Run an xterm like 'xterm -ls &' and then from that terminal's prompt try
running your ssh command and see what happens.

I start my slogin xterm windows much like this (from ctwm):

	xterm -cn -rw -sb -si -sk -sl 2048 -ziconbeep 1 -e slogin -C &

but I use SSH-3.2, not OpenSSH.

(BTW, I set "reply-to:" to be the list for a reason -- I don't need two
copies of every reply.  Feel free to do the same!  :-)

								Greg A. Woods

+1 416 218-0098;            <>;           <>
Planix, Inc. <>; VE3TCP; Secrets of the Weird <>