Subject: Re: LJ1200
To: Nathan J. Williams <>
From: Jukka Marin <>
List: netbsd-users
Date: 12/05/2002 23:06:48
On Thu, Dec 05, 2002 at 07:00:30PM +0000, MLH wrote:
> On 5 Dec 2002 08:40:01 -0600, Jukka Marin wrote:
> > So I got myself a HP LaserJet 1200, hooked it up to NetBSD 1.6 USB port,
> > NetBSD recognized it - and I can print absolutely nothing.
> > 
> > If I cp a ps file to /dev/ulpt1 (that's the device), cp takes a long time
> > and produces no output.  If I cp a ps file to /dev/ulpn1, it doesn't take
> > a long time - but still no output.  I have tried power-cycling the printer,
> > no help.  I get no messages in syslog.
> What shows up in /var/log/messages when you 1) power-cycle the
> printer 2) disconnect and reconnect the printer?

ulpt1 at uhub2 port 2 configuration 1 interface 0
ulpt1: HewLett Packard HP LaserJet 1200, rev 1.10/1.00, addr 5, iclass 7/1
ulpt1: using bi-directional mode

I found these:

I wonder if this is my problem, too.. how do I check which endpoint ulpn
is using?  How do I fix the endpoint number, if it's 3?

I would really like to retire my 15-year-old (I think) Canon LBP-8 II
because it's very slow with Ghostscript and because I can wipe the ink
off the sheets with my fingers :) :(