Subject: Re: HP LJ1200
To: None <netbsd-users@NetBSD.ORG>
From: MLH <>
List: netbsd-users
Date: 12/05/2002 19:00:30
On 5 Dec 2002 08:40:01 -0600, Jukka Marin wrote:
> So I got myself a HP LaserJet 1200, hooked it up to NetBSD 1.6 USB port,
> NetBSD recognized it - and I can print absolutely nothing.
> If I cp a ps file to /dev/ulpt1 (that's the device), cp takes a long time
> and produces no output.  If I cp a ps file to /dev/ulpn1, it doesn't take
> a long time - but still no output.  I have tried power-cycling the printer,
> no help.  I get no messages in syslog.
> My HP DJ970Cxi works, and so does an Epson USB scanner, so I believe the
> USB ports are OK.
> According to mailing list logs, it should work.. so what am I doing wrong
> this time?

What shows up in /var/log/messages when you 1) power-cycle the
printer 2) disconnect and reconnect the printer?

Also, I found mine didn't work when I plugged my cardreader into
the motherboard port right next to my printer. Worked when I moved
the reader to the other set of usb ports, even though they are
supposedly on the same port and interface:

ulpt0 at uhub1 port 1 configuration 1 interface
ulpt0: Samsung Electronics Co., Ltd. Samsung ML-1430,
       rev 1.10/1.00, addr 2, iclass 7/1
ulpt0: using bi-directional mode
umass0 at uhub0 port 1 configuration 1 interface
umass0: PQI Travel Flash, rev 1.10/2.05, addr 2
umass0: using SCSI over Bulk-Only