Subject: Re: PoPToP and Win9x VPN clients
To: Quentin Garnier <>
From: J. Buck Caldwell <>
List: netbsd-users
Date: 10/01/2002 14:31:24
> I'm using NetBSD 1.6-i386. I've installed the ppp-mppe package,
>> >renamed> then linked/usr/sbin/pppd to /usr/pkg/sbin/pppd, modload'ed
>> >mppe.o, and> started /usr/pkg/sbin/pptpd. The configs are below:
>> > 
>> > You don't have to link /usr/sbin/pppd. pptpd is aware of which pppd
>> > call.
>> I can't agree - I tried it without doing the link, and pppd complained
>> about the +chapms &etc lines in the /etc/ppp/options - so it was calling
>> the stock pppd.
> There's a simpler way of doing this : 'make install POPTOP_USE_MPPE=yes'
> in net/poptop. Then poptop is ./configure'd with the correct path to pppd.

I see. I went ahead and removed the package and re-compiled/installed with the
above option and indeed, it did start referencing the correct PPPd. I recompiled
in the (vain) hope that it might fix my real problem.

> Anyway, that's not the source of your problem. The first thing to do is
> removing the 'require-chap' line of your pppd config. I'm not sure if it
> is possible to negociate Microsoft's encryption when not using Microsoft's
> own "tweaks" of CHAP. It it still doesn't work, try without encryption,
> using PAP, using either version of CHAP-MS and so. Thus it'll be easier to
> tell where the problem lies.

I've now tried removing 'require-chap' and just about every other line, seperately
and in groups, from the config. It just seems that for some reason the PPPd isn't
communicating. As you saw from my log, it attatches the ppp0 to ttyp1, then pretty
much hangs waiting for communication. Is there something else that I may have
forgotten? I see two ppp* devices when doing 'ifconfig -a' - so ppp is compiled in.
Do I need to do anything other than 'modload /usr/pkg/lkm/mppe.o' to load the
encryption module?

  - J. Buck Caldwell

   "Every year, we pass the anniversary of our own death."
                                             - B. Banzai