Subject: RE: Problems tracking -current
To: 'Manuel Bouyer' <>
From: Rose, Brian <>
List: netbsd-users
Date: 09/25/2002 12:50:30
-----Original Message-----
From: Manuel Bouyer []
Subject: Re: Problems tracking -current

> On Wed, Sep 25, 2002 at 10:36:11AM -0400, Rose, Brian wrote:
> I tried the other USA mirror to no avail. Same problem.
>How did you try it ? just changing the cvs login isn't enouth,
>you also have specify it to every cvs command:
>cvs -d :pserver:anoncvs@<cvs server name>:/cvsroot ...

I did the following at the BASH prompt and noticed that the servers do not
match (line 3 and line 5)!

  # ; export
  # env | grep CVS
  # cvs update -d -P Connection timed out
  cvs [update aborted]: end of file from server (consult above messages if

I also tried your example and got more or less the same error.

  # cvs -d update -d -P
  cvs [update aborted]: connect to failed:
Connection timed out

> I also tried this from multiple locations (work and home) and at various
> times during the day. All with the same problem.
> I'd really like to avoid setting up a local CVS archive and I don't think
> that FTP'ing the sources is the most elegant solution.
> Any ideas why I would get connection timeouts? Perhaps my company and ISP
> firewalls are blocking a port? Is there any way for me to diagnose a
> connection to the anoncvs servers?
>You can try this to see if the connection itself works:
>telnet <anoncvs name> 2401

  # telnet 2401
  telnet: Unable to connect to remote host: Connection timed out

Are these connection timeouts a symptom of a port being blocked? Or is there
something else going on?

Thank you for your help.

Manuel Bouyer, LIP6, Universite Paris VI. 
     {Net,Free}BSD: 23 ans d'experience feront toujours la difference