Subject: installing 1.6 from a CD on a two-disk system?
To: None <>
From: Steve Bellovin <>
List: netbsd-users
Date: 09/18/2002 13:01:45
After upgrading one of my machines to 1.6, I burned a CD, per the 
instructions at
I tried using that CD on a system with two SCSI disks and a SCSI CD-ROM.
It detected sd0 and sd1, and asked if I wanted to upgrade sd0.  I 
agreed, at which point it tried to fsck /dev/rsd1a.  I don't know why 
it was doing anything with sd1a...  fsck asked if the disk should be 
marked clean (there were no errors, and from the file counts it was 
definitely doing sd1a, not sd0a); I agreed, but sysinst said that the 
fsck failed.  Next time, I tried saying "no", but it was equally 
unhappy.  I went into the utility shell -- fsck said that the file 
system was clean.  I forced fsck to look at it, via -f, and tried 
sysinst again.  No joy -- it still tried to fsck rsd1a, still thought 
there was a problem, and still refused to proceed.

But the really mysterious part is that when I retried the upgrade using 
boot floppies, it all just worked, with none of the nonsense.  Has 
anyone else seen anything like that?

		--Steve Bellovin, (me) ("Firewalls" book)