Subject: Re: Starting Browsers
To: Jeremy C. Reed <>
From: Curt Sampson <>
List: netbsd-users
Date: 09/05/2002 12:54:02
On Wed, 4 Sep 2002, Jeremy C. Reed wrote:

> >     Curt>     Cannot find a schema for galeon preferences. Check your
> >     Curt>     gconf setup, look at galeon FAQ for more info.
> I overlooked this message. I thought I was reading the galeon list.
> My diary reminds me that I had same issue in May. In my case, my problem
> was "my ~/.gconf and ~/.gconfd directories and files were owned by root.
> (I guess I ran skipstone as root.) So I chowned them and galeon worked."

Yeah, my .gconf and .gconfd directories were owned by root, too.
But this whole package seems pretty severely broken. For example,
the clean() function in the galleon-config-tool script starts with:

    if ps hu -C galeon-bin | grep `id -un` >/dev/null 2>&1; then
	echo "Sorry, this script won't work while galeon is running"

which of course will always make it print this message. Grrr.

So I deleted the .gconf and .gconfd directories, ran galleon-config-tool
--clean, and tried --install-schema again, and it's still trying to
write stuff all over /usr/pkg. That kind of thing just makes me too
worried about security to want to use this.

Curt Sampson  <>   +81 90 7737 2974
    Don't you know, in this new Dark Age, we're all light.  --XTC