Subject: Re: rarpd vs. 1.4.3
To: John Nemeth <>
From: Greg A. Woods <>
List: netbsd-users
Date: 03/23/2002 14:56:06
[ On Saturday, March 23, 2002 at 03:43:52 (-0800), John Nemeth wrote: ]
> Subject: rarpd vs. 1.4.3
>      Are there any known problems with rarpd in NetBSD 1.4.3?

There are problems with rarpd on all versions of NetBSD up to and
including 1.5W (and no doubt beyond -- none of the changes in the most
-current sources would appear to make the final bugs go away).

There were some changes prior to the 1.4 branch that fixed some of the
bugs, but even with 1.5W I often have to restart rarpd.  Prior (i.e. in
1.3.2) I have to kill rarpd, delete any partial ARP entries, then
restart rarpd.  Sometimes I have to do this multiple times, but that may
be because a stray packet from the booting host gets inbetween two of
the steps or some such.  (in 1.3.2 a second boot almost never works
until I do these steps)

I've been meaning to file a formal PR about this, but I've been avoiding
rebooting my workstation enough lately that I haven't been able to
gather the remaining information that I'd like to learn before I do so.

>  I used
> to netboot sparcs from my laptop when it was running 1.4.2, but now
> with 1.4.3 and the exact same setup, I can't get it to work.

The only difference in the code for rarpd itself between 1.4.2 and 1.4.3
is a fix for a format string "bug" that was pulled up from a change mad
prior to the 1.5 branch.  There could be related changes in the kernel
though that I'm not aware of.

> Just to make sure I wasn't going crazy, I tried netbooting from my
> gateway machine which is still running 1.4.2 (it will probably get
> moved to 1.5.3 when that is released) and it worked fine.  I even tried
> copying rarpd from the 1.4.2 machine to my laptop and it still didn't
> work.  Does anybody have any ideas?

It sounds like you've restarted rarpd after an unsuccessful boot, but if
not try that.  You might as well also try doing the ARP table cleanup as
I do with 1.3.2 (i.e. while rarpd is not running).

>  I don't want to upgrade my laptop
> to 1.5.x since it is only a 486SX/33 with only 8M RAM.

As an aside I'll note you will probably want to upgrade it to 1.6 when
that's available (unless you can justify going to some very recent
snapshot of -current now).  1.6 will probably get more out of that
machine than 1.4 can now.

								Greg A. Woods

+1 416 218-0098;  <>;  <>;  <>
Planix, Inc. <>; VE3TCP; Secrets of the Weird <>