Subject: rarpd vs. 1.4.3
To: None <>
From: John Nemeth <>
List: netbsd-users
Date: 03/23/2002 03:43:52
     Are there any known problems with rarpd in NetBSD 1.4.3?  I used
to netboot sparcs from my laptop when it was running 1.4.2, but now
with 1.4.3 and the exact same setup, I can't get it to work.  All I get

Feb 22 19:25:39 jnlap rarpd[221]: received packet on ep0
Feb 22 19:25:39 jnlap rarpd[221]: no IP address for 08:00:20:80:9b:7f

I triple checked everything.  My /etc/ethers has:

00:03:e3:c2:00:0a       sparc32
08:00:20:80:9b:7f       sparc64

My /etc/hosts has:    sparc32    sparc64

and my /etc/nsswitch.conf has:

hosts:          files dns

Just to make sure I wasn't going crazy, I tried netbooting from my
gateway machine which is still running 1.4.2 (it will probably get
moved to 1.5.3 when that is released) and it worked fine.  I even tried
copying rarpd from the 1.4.2 machine to my laptop and it still didn't
work.  Does anybody have any ideas?  I don't want to upgrade my laptop
to 1.5.x since it is only a 486SX/33 with only 8M RAM.