Subject: ssh hangs for a while waiting to connect
To: None <>
From: Andrew Basterfield <>
List: netbsd-users
Date: 03/05/2002 21:07:06
I'm trying to connect to my NetBSD/sparc 1.5.2 machine from a linux box
running OpenSSH 3.02p1. It will connect but there is a delay of several
minutes before the password prompt.

I experience the delay connecting to the NetBSD box from a variety of
different ssh clients on different boxes. They all connect quickly between

I have full IPv4 reverse mapping in the DNS they use and nslookup on all
machines works fine for both forwards and reverse lookups.

If I force ssh to use SSH v1 protocol it produces the password prompt
within 10 seconds.

If I ssh the NetBSD box's IPv4 DNS name on the NetBSD machine it connects
within 5 seconds. 

If I run ssh with the debug option I get:

  debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
  <several minutes delay>
  debug1: Host 'saurus.privnet' is known and matches the DSA host key.

If I run sshd on the NetBSD box with debug option I get:

  debug1: Sending SSH2_MSG_KEX_DH_GEX_GROUP
  <several minutes delay>
  bits set 1035/2049

Is this due to an incompatibility between OpenSSH 3.02p SSH2 protocol and
NetBSD's implementation of OpenSSH, or have I screwed up? Is there a fix
apart from using the SSH1 protocol?



sparc sun4c stuff :
personal email    : bob at lostgeneration dot freeserve dot co dot uk