Subject: FFS filesystem with blocksizes != 512
To: None <>
From: Michael Kukat <>
List: netbsd-users
Date: 01/25/2002 23:41:47

i just got a fine HP 200t to my equipment, a cute "little" optical disk
jukebox with 144 slots and 4 drives. 3 drives are working stable after a
little maintenance, the 4th drive is to be repaired soon.

Now i tried to create a FFS filesystem on a medium, and i recognized the
following strange things:

1) disklabel's behaviour:

bytes/sector: 1024
total sectors: 314569
  c:   629138        0     unused        0     0         # (Cyl.    0 - 307*)

this is the kernel-generated disklabel for the media. 1024 bytes/sector is ok,
the total sectors is also ok, but the c: partition is built upon 512 bytes/sec,
and therefore, it is a bit unusable, disklabel won't save the label if i
just take these values.

2) newfs
I altered the c: and a: partition, entered the real total sectors here, used
a block size of 1024 (also tried 2048), and did newfs. result:
write error: 314568
wtfs: Invalid argument

if i use newfs -S 1024, i get the same error. Is FFS not capable of blocksizes
other than 512?

I know, MO is not really intended to be a true direct-read/write access device,
but maybe this problem is more generic.
As a different test, i did mkisofs of some dirs on the device directly, with
the success to be able to mount the partition as cd9660-fs without any

Is there a hack to use FFS (and maybe even CCD, which i didn't test for now)
with blocksizes like 1024 or 2048, or is this a bug?


--    Home network powered by: NetBSD OpenBSD FreeBSD IRIX
Solaris AIX HP-UX Tru64 MUNIX Ultrix VMS SINIX Dolphin_Unix OpenStep MacOS A/UX