Subject: Re: Setting up ipnat with NetBSD and OSX[solved]
To: Martin Husemann <>
From: Ian P. Thomas <>
List: netbsd-users
Date: 12/31/2001 11:37:21
On Mon, Dec 31, 2001 at 10:37:27AM +0100, Martin Husemann wrote:
> > This doesn't resolve hosts, packets make it out, but never make it back 
> > to the Mac.
> > nameserver    
> > nameserver    
> > 
> > This does, when running the cache only name server on the NetBSD box
> > nameserver
> So, since your setup looks sane, and everything seems to work besides name
> resolution, I bet this is some subtle typo or syntax error in the OSX setup
> for the nameserver. Have you tried a single entry like
>   nameserver    
> there?
> Martin

	I've tried with a single entry.  There are two ways to add them to 
resolv.conf, through the graphical setup for TCP/IP and using vi in a terminal.
I've done it both ways with the same results.  It seems like the udp packets 
leave the Mac, are translated to my dynamically assigned IP and sent out to the
DNS servers with no problem.  After using tcpdump to monitor activity on my internal
interface on the router, fxp0, it shows that the responses never make it back to 
this interface.  The responses do make it back to the ppp0 interface though.
This seems to be where the problem is.


Do You Yahoo!?
Get your free address at