Subject: Re: eggdrop 1.6.6 on NetBSD 1.5 release branch
To: Brian A. Seklecki <>
From: Stephen Brown <>
List: netbsd-users
Date: 12/02/2001 18:31:05
> > The 8.3.4 version is the one that ./configure picks up automatically, from
> > /usr/local/lib
> s/autoconf/./configure/g

Don't know what to do with that information, but...

> Ahh the great packge v.s. tarball conflict rages on.  Some ./configure's
> have flags like "--with-libs-from" or "--with-incs-from" that you can set
> to /usr/pkg/[include/,lib/].
> The other option is to:
> export LDFLAGS="-L/usr/pkg/lib"
> export CPPFLAGS="-I/usr/pkg/include"

Tried the ./configure --with additions before, and they could not find any
libraries whatsoever.  Just tried the two export items above, before doing
the ./configure, make config and make, and same error came up, as before..
for reference, it is below.

--- Paste

gcc -pipe -o ../eggdrop bg.o botcmd.o botmsg.o botnet.o chanprog.o cmds.o
dcc.o  dccutil.o dns.o flags.o language.o main.o mem.o misc.o misc_file.o
modules.o net.o rfc1459.o tcl.o tcldcc.o tclhash.o tclmisc.o  tcluser.o
userent.o userrec.o users.o  -L/usr/local/lib -ltcl83 -lm md5/md5c.o
compat/*.o `cat mod/mod.xlibs`
/usr/local/lib/ warning: tmpnam() possibly used unsafely, use
mkstemp() or mkdtemp()
strip ../eggdrop
Successful compile: eggdrop

Shared object "" not found
*** Error code 1  

--- End paste

> The other hack is to: "ln -s /usr/pkg /usr/local", but watch out for
> trickery and black magic in some 3rd party stuff.

Would that resolv the issue, say over the use of installing a newer
version of the TCL linux fashion?  i.e. extracting archive manually,
./configure ing, make, make install to default source locations?  If so, I
might just do that.