Subject: Re: php compile problems
To: Murray Armfield <>
From: Emre Yildirim <>
List: netbsd-users
Date: 09/07/2001 02:24:18
Murray Armfield wrote:

>Are you trying to use php with apache and MySQL?
>I have found that you must build all your php requirements first then ap-
>php. If you later add php-mysql, you need to rebuild ap-php.
>This is using php4 from pkgsrc.
>I have been using apache, php4 and mysql with phpgroupware, all from pkgsrc 
>except phpgroupware.

1) Did 'make deinstall' for ap-php4 and also did a 'make clean'
2) Did 'make deinstall; make clean' for php4-mysql and then 'make install'
3) Did 'make install' for ap-php4

Same result.
I'm trying to get PostNuke to work, which requires MySQL and PHP4.  So 
far I'm getting:

Fatal error: Call to undefined function: mysql_pconnect() in 
/usr/local/share/httpd/htdocs/mutant/html/install.php on line 347

during the installation process.  That's the part where PostNuke is 
supposed to create a
MySQL database, but it never gets that far.  So "undefined function" 
usually means that
it doesn't have support for MySQL.  Also when I do <? phptest(); ?> I 
get the following:

NetBSD santos 1.5X NetBSD 1.5X (MILLENIUM) #1: Tue Jul 31 15:25:26 CDT 2001
root@santos:/usr/src/sys/arch/i386/compile/MILLENIUM i386

Build Date
Jul 31 2001

Configure Command
'./configure' '--without-gd' '--without-mysql' '--without-pcre-regex' 
'--with-gettext=/usr' '--with-yp' '--with-zlib' 
'--with-config-file-path=/usr/local/etc' '--with-system-regex' 
'--with-exec-dir=/usr/local/libexec/php4' '--enable-track-vars' 
'--enable-discard-path' '--enable-memory-limit' '--enable-sysvsem' 
'--enable-sysvshm' '--enable-wddx'
'--enable-sockets' '--with-dbase' '--with-filepro' 
'--with-apxs=/usr/local/sbin/apxs' '--host=i386--netbsd'

(not the --without-mysql flag)

And a whole bunch of other stuff, which doesn't mention MySQL anywhere. 
 My php.ini file
in /usr/local/etc has "" in it.  So I really don't 
know what the problem is.
Could it be something else?  Is there a way I can find out if MySQL 
support is included in
my PHP4?  I already tried <? mysql_connect(); ?> which again said 
"Undefined function".

I'm sorry for posting this to the list again, but I'm sure someone out 
there has PHP4 and
MySQL working and is running NetBSD, than can shed some light into this :-)