Subject: Re: How to restore a multi volume dump?
To: None <>
From: Shannon Hendrix <>
List: netbsd-users
Date: 07/01/2001 21:47:23
On Sun, Jul 01, 2001 at 06:18:41PM -0400, Greg A. Woods wrote:
> [ On Sunday, July 1, 2001 at 23:14:12 (+0200), Matthias Scheler wrote: ]
> > Subject: How to restore a multi volume dump?
> >
> > I want to restore a multi volume dump with "restore rf $TAPE. But when
> > the end of the first tape is reached "restore" reports a read error
> > instead of asking for a tape change. I tried to eject the tape manual
> > but it still has the tape device opened. The only option is to abort
> > the restore. What am I doing wrong?
> That sounds very similar to PR#10826, and to problems I've encountered
> in the past too.  I haven't had to do multi-volume dumps in some time
> though so I don't have any recent experiences with managing them.

I had a similar problem using tar to do a large backup. Normally tar
would ask for another tape. Instead what happened was I came into the
computer room with my sparc's console spewing SCSI messages about the
end of the tape, and tar being pretty well hung until I killed it.

Previously in NetBSD 1.4.3 this always worked fine. However, I was
running 1.5.1beta2 when this error occurred, and I just went back to 1.5
today. I'll do another test and see if it's something post-1.5 causing
this on my system.

 "Consulting wouldn't be what it is today without Microsoft          | | |
 Windows" -- Chris Pinkham                                           | | |
________________________________________________________________    /  |  \
s h a n n o n @ w i d o m a k e r . c o m                         _/   |   \_