Subject: pkgsrc rpm-2.5.4 trouble
To: None <,>
From: Gerald C. Simmons <>
List: netbsd-users
Date: 06/17/2001 21:53:36
In the process of building communicator-4.77, rpm-2.5.4 gets built. I get the

cc -o rpm -static rpm.o query.o install.o verify.o checksig.o ftp.o url.o build.o  -Wl,-R/usr/pkg/lib \
 -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/pkg/lib -L/usr/pkgsrc/misc/rpm/work/rpm-2.5.4/lib \
 -L/usr/pkgsrc/misc/rpm/work/rpm-2.5.4/build -L/usr/pkgsrc/misc/rpm/work/rpm-2.5.4/misc \
 -L/usr/pkgsrc/misc/rpm/work/rpm-2.5.4/popt -lrpmbuild -lpopt -lrpm -lmisc -L/usr/pkg/lib -lintl \
 -L/usr/pkg/lib  -L/usr/local/lib  -lz   \

signature.o: warning: tempnam() possibly used unsafely, use mkstemp() or mkdtemp()
realpath.o: warning: getwd() possibly used unsafely, consider using getcwd()
/usr/pkgsrc/misc/rpm/work/rpm-2.5.4/misc/libmisc.a(realpath.o): Definition of symbol `_realpath' (multiply defined)
/usr/lib/libc.a(getcwd.o): Definition of symbol `_realpath' (multiply defined)
collect2: ld returned 1 exit status
gmake: *** [rpm] Error 1
*** Error code 2

*** Error code 1

*** Error code 1


Upon investigation, I found that removing realpath from libmisc.a in
rpm-2.5.4/misc removed this conflict.

Is this the proper way to resolve this???

Does the rpm-2.5.4 package need a patch to remove this???

Gerry Simmons