Subject: Re: php4-imap problems (imp)
To: Jarkko Teppo <>
From: Rogier Krieger <>
List: netbsd-users
Date: 06/05/2001 14:51:57
On Thu, Mar 29, 2001 at 03:21:48PM +0300, Jarkko Teppo wrote:
> Hello all!
> While trying to build imp from pkgsrc on a freshly installed 1.5 i386
> machine I ran into a stupid problem: php won't accept the module.
> root@machine:/usr/pkg/etc > php
> /usr/pkg/lib/php/extensions/no-debug-non-zts-20001214/ Undefined PLT 
symbol "SSL_library_init" (reloc type = 7, symnum = 885)
> root@machine:/usr/pkg/etc > 
> I load it as a module in apache and it won't work there either. To recap:
> fresh 1.5, pkgsrc.tar.gz downloaded today. I've tried fiddling with
> php.ini to no avail.
> Any help appreciated!

In my experience, you need to have ap-ssl (mod_ssl) installed and,
as a consequence, start apache with the 'startssl' option.

The php4-imap module will then start without a glitch. There's no
further need to use any SSL'ised services if you don't want to,
but for the php4-imap module, the ap-ssl module itself is required.

You can find it in the /usr/pkgsrc/www/ap-ssl directory.

Good luck,

Rogier Krieger

Eagles fly, but weasels don't get caught in jet engines