Subject: Booting NetBSD
To: <>
From: Rakhesh Sasidharan <>
List: netbsd-users
Date: 01/31/2001 01:55:49
What are the steps that one need follow to install NetBSD without going
through the install program ?   I tried the following today, and am unable
to boot into NetBSD (1.5, btw):

1. Made the boot floppies, and booted with them. 
2. Created a NetBSD partition (on wd0), disklabel-ed it, and mounted them
under /mnt and /mnt/usr. 
3. Then I mounted the partition where I had the  .tgz files (base.tgz etc)
under /mnt2. 
4. After this, I untarred those files to /mnt.
5. Then, cd /dev && ./MAKEDEV all. 
6. And: /usr/mdec/installboot -v /usr/mdec/biosboot.sym /dev/rwd0a 
7. reboot.

I use GRUB to boot my OSes, and I gave it the proper commands (root,
chainloader, boot), but it refuses to boot.  I get some screen output like
"^_@%"  and the machine hangs.

I then used my boot floppies to boot into NetBSD, and reissued the
"installboot" command from there.  But still, same response from GRUB.

Then I tried to install the NetBSD boot-selector, and see if that might
work.  Nope.  I the function key to boot NetBSD, and I just get a
numerical output (ie, I press F5, and I get 3).

I have a 17 GB hard-disk, and NetBSD occupies the last 10 GBs.  It could
be that NetBSD is beyond the "bootable region," but point is I have booted
NetBSD-1.4.2 and OpenBSD 2.7 from this same partition using GRUB
(NBSD boot-selector didn't do the job).

My only option remaining is install NBSD using the install program; but I
thought I'd ask you guys once. :)


Rakhesh Sasidharan