Subject: Re: Problem adding a second disk
To: Michael Roark <>
From: Manuel Bouyer <>
List: netbsd-users
Date: 01/06/2001 16:10:50
On Fri, Jan 05, 2001 at 02:28:59PM -0500, Michael Roark wrote:
> I followed the instructions in the NetBSD guide to add a second disk. I ran
> into problems when I tried to write the disklabel to a temp file. I think I
> may have screwed something up when I did a fdisk -u wd1. Honestly, I haven't
> had a problem with disk geometry before, but this disk (Quantum Fireball SE
> 4.3) didn't want to behave as a master disk during install (a 1.5 install -
> on reboot, after POST, I got an invalid partition table error), so I used a
> different disk for master (a Western Digital) and the Quantum for slave. The
> OS install to the WD was fine. On boot, the machine sees the Quantum disk
> with the geometry that matches the bios. But now, after trying fdisk and
> disklabel, I am stuck. If I try to start over with "fdisk wd1", I get an
> "inappropriate ioctl for device error".
> I can't find anything in the archives about this so I am kind of lost. Is
> there a way to start over or have I hosed the disk?

Try: dd if=/dev/zero of=/dev/rwd1d bs=64k count=100

This will erase the partition table.

Manuel Bouyer <>