Subject: Problem adding a second disk
To: None <>
From: Michael Roark <>
List: netbsd-users
Date: 01/05/2001 14:28:59
I followed the instructions in the NetBSD guide to add a second disk. I ran
into problems when I tried to write the disklabel to a temp file. I think I
may have screwed something up when I did a fdisk -u wd1. Honestly, I haven't
had a problem with disk geometry before, but this disk (Quantum Fireball SE
4.3) didn't want to behave as a master disk during install (a 1.5 install -
on reboot, after POST, I got an invalid partition table error), so I used a
different disk for master (a Western Digital) and the Quantum for slave. The
OS install to the WD was fine. On boot, the machine sees the Quantum disk
with the geometry that matches the bios. But now, after trying fdisk and
disklabel, I am stuck. If I try to start over with "fdisk wd1", I get an
"inappropriate ioctl for device error".

I can't find anything in the archives about this so I am kind of lost. Is
there a way to start over or have I hosed the disk?

Any input would be great.