Subject: Re: A FreeBSD problem (off topic ?)
To: Steinar Hamre <>
From: Rakhesh Sasidharan <>
List: netbsd-users
Date: 08/25/2000 10:25:19
We had communicated earlier, on the matter of accessing logical partitions
from FreeBSD.  As of my last mail, I had said I would try out your
suggestions and get back to you.  

I did, and ran into some problems:

> You have 4 primary partitions. One (and only one) of these may have
> partition id 5 "Extended DOS" and is partitioned futher in a "linked
> list" manner into "logical" (sub)partitions.
> FreeBSD normally handles logical partitions by assigning them
> partition number 5 and upwards (just like Linux (and HURD (acctually
> the HURD partitioning system is modeled very closely after FreeBSD))).
> Use /dev/da0s5 and so on for logical partitions. If you lack a device,

I did that.  In Linux, I have hda5 (100 MB /), hda6 (**MB swap), hda7 (100
MB /var), and hda8 (2100 MB /usr).  I MAKEDEV'd wd0s[5-8]c, and all the
devices have been created.

Then I did 'mount -t ext2fs /dev/wd0s5c /mnt' and that too went fine.
After that, I cd'd to /mnt, and typed 'ls'.  With that there was a display
of some error messages (in bold), and the machine had to reboot in 15
seconds.  Some details:

	Fault trap: 12
	Page fault while in kernel mode.
	code: supervisor write; page not present.

These are some of the things I copied from the screen in those 15 seconds.
I made an entry in syslog.conf as 'kern.*	/var/log/kern-log' to try
and log that message, but I couldn't.  If you have any idea of how I could
log messages in such an 'emergency', I shall do that.

> Note that although FreeBSD fdisk cannot create logical partitions,
> FreeBSD have no problem using them, and all primary and logical
> partitions can be subpartitioned further with a disklabel (but you do
> not put a disklabel on the extended partition itself), resulting in
> partition names like /dev/da2s16f. I'm using this technique to create
> 62 partitions on a single disk. (with a maximum of 7 usable partitions
> each disklabel, I need at least 9 "PC" partitions).

Again, I tried that too.
I tried 'disklabel -r wd0s5c' and 'disklabel -e -r wd0s5c' -- both gave me
some errors abt the disk being unlabelled.  I thought '-e -r' was a way to
label them.  Any suggestions ?

BTW, I tried mount-ing the ext2fs partition 'ro' also -- but that too gave
similar errors.