Subject: ahc and raidframe questions
To: None <>
From: Chris Jones <>
List: netbsd-users
Date: 06/23/1999 11:55:47
I'm in the process of setting up a machine with a RAID array hanging
off an Adaptec 2940UW.  In the process, I've discovered a few weird
things, and I was wondering if anybody could comment:

* NetBSD didn't successfully probe the disks until I told SCSISelect
  (the ahc's config program) to disable "sync negotiation" on all the
  disks.  It would complain "ahc0: board not responding", or something
  very similar.

* Doing anything with the RAID array seems pretty slow.  It took over
  two hours to initialize the parity information for a RAID5 array
  across three 9G disks.  It's currently doing a 17GB newfs, and it
  looks like that will take about an hour by the time it's done.

* Trying to speed things up, I tried options AHC_TAGENABLE and
  AHC_SCBPAGING_ENABLE.  This caused the "ahc0: board not responding"
  messages to reappear.  Running with only AHC_TAGENABLE seems to work
  fine, though.  I didn't see anything in ahc(4) saying that those two
  options were dangerous, but I guess the fact that they're not
  enabled by default should tell me something, eh?

This is an i386, 1.4 system.  2940UW with 3 Fujitsu 9GB UW disks
hanging off it.  It also has an on-board ncr and pciide.

I haven't yet tried actually reading and writing files on the RAID
array, because it's not done newfs'ing.  But it may be that actual
file operations will be pretty fast.


Chris Jones                                
           Mad scientist at large          
"Is this going to be a stand-up programming session, sir, or another bug hunt?"