Subject: Help, please, with (MO) disk device on AHA.
To: None <>
From: Hans Dinsen-Hansen <>
List: netbsd-users
Date: 05/17/1999 20:34:14
As a gift, I have received a HP C1711A magnetical optical disk device
plus 9 re-writable MO disks @ 2*325 MB each.  The disks are marked
"Formatted". Thy are with 1024 bytes per sector, 17 sectors per track,
and 18751 tracks per side.

Together with the C1711A I also received a User's Guide.  This manual
says that special nodes, e.g. (on HP-Unix) /dev/dsk/mo and
/dev/rdsk/mo should be created.  This led me to think that it might
easily be interfaced to NetBSD as a disk device.

However, when I connect the C1711A to Adaptec 1542B, I receive the
following messages (in NetBSD 1.3.2):
aha0 at isa0 port 0x330-0x333 irq 9 drq 7
aha0: model AHA-1540A/1542A/1542B, firmware 0.6
aha0: async, parity
scsibus0 at aha0: 8 targets
sd0 at scsibus0 targ 0 lun 0: <QUANTUM, FIREBALL1280S, 630C>
                                     SCSI2 0/direct fixed
sd0: 1222MB, 4135 cyl, 4 head, 151 sec,
                                 512 bytes/sect x 2503872 sectors
st0 at scsibus0 targ 2 lun 0: <WANGTEK, 5150ES SCSI ES41, B230>
                                     SCSI1 1/sequential removable
st0: rogue, drive empty
sd1 at scsibus0 targ 5 lun 0: <, , > SCSI0 0/direct fixed
sd1: sd1: mode sense (4) returned nonsense; using fictitious geometry
153MB, 153 cyl, 64 head, 32 sec, 512 bytes/sect x 314569 sectors

This leads to some major questions:

1) The User's Guide says the device is SCSI2; the QUANTUM and WANGTEK
   devices are correctly found to be SCSI2 and SCSI1, respectively.
   So why does AHA/NetBSD say that it is SCSI0?  

Which again leads to two questions:
1a) Could it be an error on one of the signal lines?  But if so, why
    do my QUANTUM and WANGTEK devices run without problems?
1b) Do disk devices and MO-devices differ in some way which cheats
    NetBSD into believing that it is a SCSI0 device?

Because of 1b), I downloaded the SCSI2 specifications  from but much to
my dismay Clause 16, Magneto Optical devices was missing.  Roberto
Rambaldi tells me that Clause 16 was missing when he fetched the

2) Does anybody have Clause 16?

Of course, in spite of above problem, I tried to disk-label one of the
disks, and I tried to make dd from and to it.  Everything resulted in
error messages, and probably no data written, as the same garbage data
is read, whatever I try to write.  Let me add that the active lamp on
the HP C1711A goes on for a period whenever I try to access it.

The User' Guide states that the disks should be "initialized" before
they are labeled.  I can only find a format program for the VAX and
the HP platforms.  I am running on the i386-platform.

Suppose, I get something to run, this leads to question 3:

3) Is there a format program that one should use, or is the
   pre-formatting sufficient?

Any help will be appreciated.

This mail has been crossposted to:
Are there better groups to go to with my question?

Hans Dinsen-Hansen
Place legs between arms. With hands firmly grab
around arms. Lift legs from ground. - Now walk.
                 Extract from the user's manual
                            of my wheel barrow.