Subject: Re: NFS troubles on NetBSD clients with RH 6.0 Linux.
To: Brian D Chase <>
From: Jason Thorpe <>
List: netbsd-users
Date: 05/16/1999 11:36:32
On Sun, 16 May 1999 11:01:01 -0700 
 Brian D Chase <> wrote:

 > Anyone here see troubles mounting NFS filesystems served from RH 6.0 on
 > their NetBSD systems?  I've tried from both 1.3.2 and 1.4 clients.  I can
 > get the filesystems to mount okay.  They show up if I run the NetBSD
 > 'mount' command, but not the under the 'df' command.  Any attmept to
 > access the filesystems or their contents results in an message stating
 > "Protocol not supported".  On the Linux side, I get messages like:
 >   May 16 10:26:37 voodoo kernel: svc: unknown version (3)
 > Which I'm taking to mean that the NetBSD clients are trying to talk with
 > the Linux server using NFSv3 but Linux the kernel can't handle it.

You can force NetBSD to use v2 mounts using with the -2 option to mount_nfs.

Or, like this:

	mount -t nfs -o -2 server:/foo /mnt

        -- Jason R. Thorpe <>