Subject: installing on i386
To: None <>
From: Oleg Polyanski <>
List: netbsd-users
Date: 01/09/1999 23:34:40

	i have some strange problems when trying to install
netbsd on my pc. i have enough memory, tekram 390u (ncr875)
scsi adapter, atapi cdrom. during boot process neither of ide
channels was recognized. so, i'm unable to use my cdrom.
another problem is with disklabel. i have 6Gb scsi disk with
real geometry 9006/6/235 (c/h/s), scsi bios requires 791/64/255
(or 6004/32/64). i choose fake geometry (that matches real
geometry, ie 9006/6/235) and go next. in the next step, disklabel
program fails to write disklabel, kernel complains 
`sd1: no disk label'. when i run `disklabel -r sd1' in shell i
see 255 (!) heads instead of choosen 6 (in fake geometry menu).
here the installation is aborted. investigation in /kern/msgbuf
does not help - nothing interesting is there.

	could anyone suggest anything useful or point to my
mistakes? any help greatly appreciated.

p.s. the most mysterious for me is that neither netbsd 1.3.2 nor
netbsd 1.3.3 won't to be installed into my disk with the exactly 
same results. i tried to install from snapshot boot floppy
(november snapshot) and both of ide channels *was* recognized)
but installation program does not work - aborts with message
`md0: / file system full'. if it is important - i try to install
netbsd on p-II box, intel 440bx chipset, plenty of RAM etc,
tekram scsi adapter.