Subject: RE: Problems with socks5 package
To: Paul Goyette <>
From: Tim Rightnour <>
List: netbsd-users
Date: 01/03/1999 08:56:50
On 03-Jan-99 Paul Goyette spoke unto us all:
#  I get the following errors installing the socks5 package.  Any hints on
#  what to do?
#  ===>  Building for socks5-1.0.2
#  ld -o -Bshareable msg.o protocol.o log.o hostname.o
#    confutil.o buffer.o cache.o wrap.o wrap_tcp.o wrap_udp.o     conf.o
#    libproto.o select.o rld.o null.o addr.o shim.o dpin.o dpinutil.o
#    upwd.o gss.o cram.o -Wl,-R/usr/pkg/lib -lcrypt 
#  ld: invalid command option `-Wl,-R/usr/pkg/lib'

It's whining because -Wl,-R is a flag to CC, that should get passed to the
linker.  socks is invoking the linker directly.

Two things come to mind:

replace ld with cc and pray.

libtool this pkg.  (preferred)

Tim Rightnour  -
Free Multi-Platform Operating System:
NetBSD Mailing lists on the web: