Subject: More info on the Dual 2940UW problem
To: '' <>
From: Scott Burns <Scott.Burns@Netcontech.Com>
List: netbsd-users
Date: 11/18/1998 17:38:30

I am getting a little desperate now.  If I don't get this thing working in 
the next week or so management is going to say put NT on it as they don't 
want  $ 12K sitting around doing nothing ;-( I can always start with a 
single controller but I would really like to use the second one with two 
drives per controller.

With the dual 2940UW cards still running into lockups right after the 
kernel prints out the biomask, ttymask etc.

I have confirmed the following:
0) This is a new Compaq Prosignia 200 - PII 300, 160MB, PCI, ISA etc. BIOS 
dated 08/17/98 Rev P05.

1) No IRQ conflicts, as a matter of fact I have disabled all non-essential 
devices on the mother board via the BIOS screens (LPT*, COM*, Floppy, both 
IDE controllers, onboard NIC, etc. etc.). Adaptec's seem to be seating them 
selves at: ahc0, irq 11, io 6000, and ahc1, irq 5, io 6400.

2) Thought it might be some other device probe in the fat kernel corrupting 
that controller, as it was on IRQ 5 which the stock kernel has hooked to 
COM3 etc, as it came on my NetBSD CD from NetBSD.COM. So I have stripped 
the kernel down to only load the 2940 driver, SCSI devices etc. All floppy, 
com port, lpt port, NICs etc. have been removed.

3) I have tried each 2940UW, cable, drive etc. individually and they work 
fine alone.

4) The 2940UW's are V1.34.3 firmware, brand new last week. Drives are 
Seagate (ST39173W) Barr 9.1 ultra wides. firmware 5958 as per the kernel 

As soon as I stick in the second 2940 the kernel loads and finds everything 
properly but right after the bio, tty, net mask stuff near the end of the 
boot, where it prints out the root file system parition, type etc. it hangs 

I tried the PCIVERBOSE option and no real extra info came out that I could 

Here is my config file for the lean kernel I built.

include "arch/i386/conf/std.i386"

maxusers	32		# estimated number of users
options 	I586_CPU
options 	I686_CPU	
options 	MATH_EMULATE	# floating point emulation
options 	DUMMY_NOPS

options 	INSECURE	# disable kernel security levels
options 	RTC_OFFSET=0	# hardware clock is this many mins. west of GMT

file-system 	FFS		# UFS
file-system 	NFS		# Network File System client
file-system 	CD9660		# ISO 9660 + Rock Ridge file system
file-system 	MSDOSFS		# MS-DOS file system
file-system 	KERNFS		# /kern

options 	INET		# IP + ICMP + TCP + UDP

config		netbsd	root on sd0a type ffs

mainbus0 at root
pci*	at mainbus? bus ?
pci*	at pchb? bus ?
pchb*	at pci? dev ? function ?	# PCI-Host bridges
pcib*	at pci? dev ? function ?	# PCI-ISA bridges
isa*	at pcib?
npx0	at isa? port 0xf0 irq 13	# x86 math coprocessor
pc0	at isa? port 0x60 irq 1		# pccons generic PC console driver
ahc*	at pci? dev ? function ?	# Adaptec [23]94x, aic78x0 SCSI
scsibus* at ahc?
sd*	at scsibus? target ? lun ?	# SCSI disk drives
st*	at scsibus? target ? lun ?	# SCSI tape drives
cd*	at scsibus? target ? lun ?	# SCSI CD-ROM drives
ch*	at scsibus? target ? lun ?	# SCSI autochangers
include	"arch/i386/conf/GENERIC.local"

pseudo-device	loop			# network loopback
pseudo-device	pty		64	# pseudo-terminals

Here is the /var/log/messages output from the stripped down kernel when I 
only have one controller in and pretty much every thing turned off in CMOS. 
This also had sync nego. disabled on the sd0 drive so I didn't get the 
20MHz 16-bit mode, normally I do. When it hangs with the two controllers 
/var/log/messages is not updated ;-(:

Nov 18 03:22:56  syslogd: restart
Nov 18 03:22:56  /netbsd: Copyright (c) 
1996, 1997, 1998
Nov 18 03:22:56  /netbsd:     The NetBSD Foundation, Inc. 
 All rights reserved.
Nov 18 03:22:56  /netbsd: Copyright (c) 1982, 1986, 
1989, 1991, 1993
Nov 18 03:22:56  /netbsd:     The Regents of the 
University of California.  All rights reserved.
Nov 18 03:22:56  /netbsd: 

Nov 18 03:22:56  /netbsd: NetBSD 1.3.2 (ncti102_ncti_com) #0: Wed Nov 18 
03:21:03 PST 1998
Nov 18 03:22:56  /netbsd:     root@:/usr/src/sys/arch/  
Nov 18 03:22:56  /netbsd: cpu0: family 6 
model 5 step 2
Nov 18 03:22:56  /netbsd: cpu0: Intel Pentium Pro 
Nov 18 03:22:56  /netbsd: real mem  = 167374848
Nov 18 03:22:56 
 /netbsd: avail mem = 163381248
Nov 18 03:22:56  /netbsd: using 2068 
buffers containing 8470528 bytes of memory
Nov 18 03:22:56  /netbsd: 
mainbus0 (root)
Nov 18 03:22:56  /netbsd: pci0 at mainbus0 bus 0: 
configuration mode 1
Nov 18 03:22:56  /netbsd: pchb0 at pci0 dev 0 function 
Nov 18 03:22:56  /netbsd: pchb0: vendor 0x8086 product 0x1237 (rev. 
Nov 18 03:22:56  /netbsd: vendor 0x1013 product 0x00b8 (VGA display, 
revision 0x45) at pci0 dev 10 function 0 not configured
Nov 18 03:22:56 
 /netbsd: ahc0 at pci0 dev 11 function 0
Nov 18 03:22:56  /netbsd: ahc0: 
interrupting at irq 11
Nov 18 03:22:56  /netbsd: ahc0: aic7880 Wide 
Channel, SCSI Id=7, 16 SCBs
Nov 18 03:22:56  /netbsd: scsibus0 at ahc0 
channel 0: 16 targets
Nov 18 03:22:57  /netbsd: ahc0: target 0 using 16Bit 
Nov 18 03:22:57  /netbsd: sd0 at scsibus0 targ 0 lun 0: <SEAGATE, 
ST39173W, 5958> SCSI2 0/direct fixed
Nov 18 03:22:57  /netbsd: sd0: 8683MB, 
7501 cyl, 10 head, 237 sec, 512 bytes/sect x 17783240 sectors
Nov 18 
03:22:57  /netbsd: vendor 0x0e11 product 0xae35 (miscellaneous network, 
revision 0x10) at pci0 dev 16 function 0 not configured
Nov 18 03:22:57 
 /netbsd: pcib0 at pci0 dev 20 function 0
Nov 18 03:22:57  /netbsd: pcib0: 
vendor 0x8086 product 0x7000 (rev. 0x01)
Nov 18 03:22:57  /netbsd: vendor 
0x8086 product 0x7010 (IDE mass storage, interface 0x80) at pci0 dev 20 
function 1 not configured
Nov 18 03:22:57  /netbsd: isa0 at pcib0
Nov 18 
03:22:57  /netbsd: npx0 at isa0 port 0xf0-0xff: using exception 16
Nov 18 
03:22:57  /netbsd: pc0 at isa0 port 0x60-0x6f irq 1: color
Nov 18 03:22:57 
 /netbsd: pc0: console
Nov 18 03:22:57  /netbsd: biomask 800 netmask 800 
ttymask 802
Nov 18 03:22:57  /netbsd: boot device: sd0
Nov 18 03:22:57    
/netbsd: root on sd0a dumps on sd0b
Nov 18 03:22:56  savecore: can't find 
device 146/48
Nov 18 03:25:49  syslogd: exiting on signal 15