Subject: Re: Problems with ksh in NetBSD 1.3.2?
To: None <,>
From: Hubert Feyrer <>
List: netbsd-users
Date: 11/11/1998 04:32:22
In article <> you wrote:
> PS1IDSTRING="($(hostname):$(whoami))"
> PS1='${PS1IDSTRING} ${PWD} $ '
> This works out very nicely, and I can do the following sort of things and
> have the prompt follow along:
> (bofh:devin) /home/devin $ cd public_html
> (bofh:devin) /home/devin/public_html $ su root
> Password:
> (bofh:root) /home/devin/public_html $ telnet foo
> SunOS 5.6 (foo)
> Username: devin
> Password:
> (foo:devin) /home/devin $
> When I try to process these statements in NetBSD, the shell will lock up, as
> if its running an infinite loop.  I have to ^C to get the prompt back.

Erm, what exactly doesn't work here and hang the box - simply setting these two variables, changing, su'ing, telnet'ing? I've tried setting the variables
and cd'ing, and this worked ok for me on both -current and 1.3.2/sparc.

> Putting echo statements in my .kshrc shows that everything is getting
> executed up to these lines.  I've tried editing them, but there is no
> combination that I've been able to find that allows the NetBSD ksh to update
> each item in the prompt string as necessary.

Can you ktrace the hanging ksh process to get an idea what's it doing?

 - Hubert

Hubert Feyrer <>