Subject: Re: pppd not exiting on hangup
To: None <netbsd-users@NetBSD.ORG>
From: Bruce Anderson <>
List: netbsd-users
Date: 07/28/1998 02:33:00
On Mon, Jul 27, 1998 12:33 PM, John Nemeth <>
>      I setup a machine running NetBSD 1.3.2 as a remote router at a
> location that doesn't have very good phone service (i.e. phone calls
> get dropped quite frequently).  I used the trick that somebody posted
> a long time ago of putting the pppd command into /etc/ttys so that
> init will keep the connection up.  This has always worked fine in the
> past, even on NetBSD 1.3.0.  But, now I'm having the problem that pppd
> doesn't always exit when the call gets dropped like it should.  I'm
> not sure if this is a serial driver problem or a problem with pppd.
> But, it is really annoying and not doing much for my reputation (every
> time I upgrade the machine one problem gets solved, but another appears).
> Does anybody have any idea where the problem lies and how to solve it?

my /etc/ttys on leopard looks like:

tty01   "/usr/sbin/pppd"                unknown on secure

and then /etc/ppp/options.tty01 looks like:

This link is for my Classic II.  No ethernet :(
what does your setup look like?
modem configuration?

This message was created and sent using the Cyberdog Mail System