Subject: Real Problems with Serial Communications and NetBSD-1.0
To: None <netbsd-help@NetBSD.ORG, netbsd-users@NetBSD.ORG>
From: Gerry Simmons Jr. <darykon!>
List: netbsd-users
Date: 02/27/1995 09:07:44
I sent a couple messages out this weekend about a serial problem I was having,
but let me be more clear about it now. First off I'm running on a 486/33 platform
with 16MB of memory and two 540MB IDE HD's. I installed a clean version of NetBSD
1.0 using the installation and upgrade floppies (long story.) I've been running with
GENERICAHA, but am able to rebuild the kernel. Here's what I see:

First, I have two 16550 serial ports on an IDE VLB I/O board. I had ttys for
/dev/tty00 and tty01 set as "off secure" as in the ttys file from the installation.
I have since set them both to "none	unknown off secure" because this is what
the O'Reilly System Administration book recommended.

Neither Tip nor Kermit will work. Tip returns "line down." Kermit's another story so
I'm sticking with tip. my device line in /etc/remote is:

Alright. Just for grins I tried "uucico." I have configuration files for another
machine running NetBSD-0.9a and UUCP 1.04. This is where it really gets weird. Uucico
is able to dialout and connected with my UUCP feed. However, after the first 2-3
Email messages have been downloaded, I get tons of bad packets, until my UUCP feed
tells me to hangup, or my entire system "locks up!" (Info from Debug file in
/var/spool/uucp, w/ -x4 option.)

It appears to me that the serial port driver is very unhappy. Can anyone give me any
clues? I'm stuck and I've been working on this all weekend.

Thanks to a few of you who initially responded with some sugesstions. I tried them
all, but to no avail. Thanks anyway guys. :-)

Gerry Simmons