Subject: Recent Status (was: HPPA Port Interest.)
To: None <>
From: Eric Schnoebelen <>
List: netbsd-ports
Date: 01/07/2000 23:12:09
Michael Shalayeff writes:
- Making, drinking tea and reading an opus magnum from Eric Schnoebelen:
- > David Brownlee writes:
- > - On Wed, 29 Dec 1999, Eric Schnoebelen wrote:
- > - 	Any status updates from people out there - anyone willing to
- > - 	manage the pge that lists status and info?
- > 
- > 	Well, I'm probably not up to a page, but I can provide
- > this status update from here:
- > 
- > 	I noticed that Mickey on the OpenBSD project updated the
- > OpenBSD tree a bit.  I _still_ wasn't able to get a cross
- > compiler to build on my OpenBSD/sparc system, so I haven't gone
- > too much farther down that path..
- cross-tools builds just fine on i386 and sparc.
- can you describe your problems before stating it does not build?
- i can confirm that it builds not only on my machine.

	Executing the following command: 
		sudo make TARGET=hppa cross-tools

left me with the following errors:
gcc -DCROSS_COMPILE -DIN_GCC -DHAIFA   -g   -DHAVE_CONFIG_H  -o cc1 toplev.o version.o tree.o print-tree.o stor-layout.o fold-const.o  function.o stmt.o except.o expr.o calls.o expmed.o explow.o optabs.o  intl.o varasm.o rtl.o print-rtl.o rtlanal.o emit-rtl.o genrtl.o real.o  dbxout.o sdbout.o dwarfout.o dwarf2out.o xcoffout.o bitmap.o alias.o gcse.o  integrate.o jump.o cse.o loop.o unroll.o flow.o stupid.o combine.o varray.o  regclass.o regmove.o local-alloc.o global.o reload.o reload1.o caller-save.o  insn-peep.o reorg.o haifa-sched.o final.o recog.o reg-stack.o  insn-opinit.o insn-recog.o insn-extract.o insn-output.o insn-emit.o lcm.o  profile.o insn-attrtab.o pa.o getpwd.o  convert.o  mbchar.o dyn-string.o graph.o sbitmap.o resource.o hash.o c-parse.o c-lang.o c-lex.o c-pragma.o c-decl.o c-typeck.o c-convert.o  c-aux-info.o c-common.o c-iterate.o obstack.o        -liberty 
/home/wylbur/eric/work/OpenBSD/src/gnu/egcs/gcc/cse.c:856: Undefined symbol `_find_hash_table_entry' referenced from text segment
/home/wylbur/eric/work/OpenBSD/src/gnu/egcs/gcc/cse.c:921: Undefined symbol `_empty_hash_table' referenced from text segment
/home/wylbur/eric/work/OpenBSD/src/gnu/egcs/gcc/cse.c:932: Undefined symbol `_create_hash_table' referenced from text segment
collect2: ld returned 1 exit status
*** Error code 1

Stop in /usr/cross/hppa/usr/obj/gnu/egcs/gcc.
*** Error code 1

Digging into OpenBSD's compiler tree was a bit more than I was up
Sunday afternoon (when I recieve the above error.)

I'm updating my OpenBSD CVS tree as I type, and will attempt
another cross build just as soon as the update is complete.

- > 	I've tried to boot Mickey's latest OpenBSD/hppa kernel
- > on one my 720, with no luck.  I haven't tried to boot anything
- > on the `spare' 712, as I haven't gotten it rigged for a serial
- > console yet.
- 720 is stated as _unsupported_ until someone w/ the box
- actually work on it. so, whom have you gotten surprised?

	I wasn't terribly suprised.  It hasn't worked before, and
I didn't really expect it to work this time, but I was taking a
chance that perhaps something unrelated caused a change in that
status.  Once I can get the cross compile environment going, I'll
go at getting the 720 supported for both OpenBSD and NetBSD..

- fyi, 712 does not support serial console.

	Actually, it does, although not in a natural, intuitive way. 
Inside HP, they have/had a large number of them set up headless
for various purposes.  However, it is not a configuration
supported outside of HP.

	The magic, gleaned from the 
list is:

	power up the 712
	abort the autoboot (press escape)
	at the BOOT_ADMIN> prompt, enter
			`boot pri isl'
	at the ISL> prompt, type
			`conspath 2/0/4.0x283' (for serial)
	at the ISL> prompt, type 
		to verify the console path is:
			`(hex) 2/0/'
	If required, retype the `conspath' command, and reverify
		until it is correct.
	Connect a terminal to the system.
	power cycle the system to bring it up on a serial

Disclaimers: This is _not_ a supported configuration by HP end
users.  If you mess up the `conspath' command, and let the
system reset, you have buggered your system into a state where
only a `dagger' board can reset it.  `dagger' boards are
available internally to HP, for their use..

	The URL of the message in the parisc-linux archive is:

	I'm going to set one of my 712's to run off a serial
console, at least for a while.  The other (my primary X display)
will continue using the standard graphical display.. :-)

Eric Schnoebelen
      Where subtlety fails us we must simply make do with cream pies.