NetBSD-Java archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkgsrc openjdk7 and eclipse and suse-12 does not work

On Fri, 16 Nov 2012 13:23:51 +0100
"S.P.Zeidler" <> wrote:

> > I had never much luck with running Eclipse on NetBSD. Now I tried
> > it with openjdk7 and all suse-12 packages under NetBSD/i386 6.0.
> > All software, including eclipse, is from pkgsrc-2012Q3 (I patched
> > the eclipse Makefile to accept openjdk7). Still no success.
> You are keeping in mind that lang/openjdk7 and lang/openjdk7-bin both
> are or rather contain native NetBSD binaries?

Yes, I realized that, but hoped it will work somehow. I guessed that
Linux emulation is still needed, because org.eclipse.swt.motif_3.0.1
only contains Linux/x86 shared objects?

Alternatively I tried to download a recent Eclipse archive from
It opens a small empty window and then a second with an error message:
'Failed to load the JNI shared library
And in the console: " shared object cannot be opened". is refering to NetBSD's, which exists. But it
seems that the library is searched in /emul/linux only, because "eclipse"
was a Linux binary? This means a NetBSD-native Java will never work with

I already would be happy if I knew how to start Eclipse under NetBSD at all. :)

Frank Wille

Home | Main Index | Thread Index | Old Index