Subject: Re: patches for native jdk6 on amd64
To: None <>
From: Bernd Ernesti <>
List: netbsd-java
Date: 11/28/2007 20:30:47
On Wed, Nov 28, 2007 at 08:16:11PM +0200, Arto Huusko wrote:
> Attached is a bunch of patches to make sun jdk6 build and run
> on -current NetBSD/amd64.
> Patch Sun sources first with patches from
> and then apply the attached patches, and follow the build instructions
> from FreeBSD patches to build JDK. You don't need libiconv, but you
> do need CUPS installed to build (or at least CUPS headers available).
> The patches do this:
>  - All /usr/X11R6 replaced with /usr/pkg

This is wrong and will not work with a native X11.