Subject: left speaker is distorted with autri SiS 7018
To: None <>
From: Jeremy C. Reed <>
List: netbsd-help
Date: 11/28/2002 16:45:46
Last winter, I hand-merged in the code from -current into 1.5.2 so I could
use my SiS 7018 using the autri(4) driver.

It sounded terrible. The sound had a constant buzzing, drumming, echoing,
sound. I could hear the music or audio, but the additional noise made it
hard to listen too. (It sounds like some type of special sound effect
where it echos the audio -- maybe some people would like it.)

So later when I upgraded to 1.6 (which had support for the sound
hardware), the audio was improved but still had that drumming, clicking,
echoing noise.

Today, I realized it was just the left channel. So I used:
  $ mixerctl -w outputs.master=0,150
  outputs.master: 7,151 -> 7,151

This makes it useful. Although with volume 7, I can still hear it a

The hardware is:

 autri0 at pci0 dev 1 function 4: Silicon Integrated System SiS 7018 Sound
 (rev. 0x02)
 autri0: interrupting at irq 11
 autri0: CMI65 codec; no 3D stereo
 audio0 at autri0: full duplex, mmap, independent
 midi0 at autri0: 4DWAVE MIDI UART

Anyone using this sound hardware?

Anyone having similar echoing/buzzing problems?

Any suggestions on how to troubleshoot this?


   Jeremy C. Reed

p.s. This is on my in-law's computer. (I wrote an article about it at
BSD Today last winter or spring.) They want to move to Windows 2000.
Especially since their printer which works perfect under Windows (and
others have said it works great under Linux), doesn't work under NetBSD.