Subject: Re: linux cross-compilation
To: Narayana Prasad <>
From: Alan Barrett <>
List: netbsd-docs
Date: 10/16/2006 10:00:56
On Mon, 16 Oct 2006, Narayana Prasad wrote:
>    I found the information at 
> very useful and still applicable(except for the patch part) to the 
> NetBSDD3.0.1 release. I think it will be worthwhile to mention that link 
> at under a kernel FAQ like "Is it 
> possible to compile NetBSD from linux?" or "Other Information" section.

I'd rather fix the bugs than point to an out of date web page that
describes a workaround.

You mentioned that the patch <
Netbsd/MandrakeLinuxBuild/linux-20030527.patch> is no longer necessary,
and the only other special instructions seem to be overriding LIBC and
LIBM on the command line.

Can you confirm that overriding LIBC and LIBM is both necessary and
sufficient to get the build to work?  What errors do you get if you fail
to override those variables?

--apb (Alan Barrett)