Subject: Re: Howto submission for setting up CUPS
To: Jonathan <>
From: Jeremy C. Reed <>
List: netbsd-docs
Date: 04/20/2004 20:39:22
On Tue, 20 Apr 2004, Jonathan wrote:

> > I didn't look at this HowTO, but setting USE_CUPS=YES before building any
> > packages should help to make sure that ghostscript-esp (or
> > ghostscript-esp-nox11) is used.
> Jeremy:
>  I suppose this is set in /etc/mk.conf? If so will this setting prevent
> the traditional Berkeley print system form being compiled? If the

Yes, set in mk.conf. No, it doesn't cheange if normal lpr/lpd is

> traditional print system is not built, then there will be no
> printer entries in /usr/bin and the CUPS commands in /usr/pkg/bin will be
> used.

Yes, you will still have both installed (on a NetBSD box).

> I looked in /usr/pkgsrc/mk/ and the only thing I saw
> pertaining to CUPS were these two entries.

Please look again. Search for "USE_CUPS". (I was about to add it and I saw
it was already there.)

The USE_CUPS is used by the to choose the esp version like
CUPS needs. USE_CUPS is also used by rewind, wine, samba packages,
libgnomeprint and kdelibs packages.

   Jeremy C. Reed