NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bin/60831: ntpd rejecting valid servers



>Number:         60831
>Category:       bin
>Synopsis:       ntpd rejecting valid servers
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Oct 01 03:10:00 +0000 2026
>Originator:     John Nemeth
>Release:        NetBSD 11.0, -current
>Organization:
>Environment:
>Description:
ntpd-4.2.8p18 introduced a strict check on ppoll and rejects servers
providing a value outside a certain range.  ppoll represents the
rate at which a client should poll a server (the client is free to
set its own polling rate, but should not go below ppoll).  RFC 5905
does not specify a range for ppoll, but does say a client should
stay within MINPOLL and MAXPOLL.  ntp-4.2.8p18 is rejecting servers
that specifies a ppoll outside this range even though everything
else is fine.  It seems that quite a few embedded servers (routers,
dedicated NTP appliances, etc), including Starlink terminals, set
ppoll to 0.  The latest NTP server is rejecting these servers, even
though they are perfectly valid time sources.
>How-To-Repeat:
Add an affected server to /etc/ntp.conf and see it get rejected.
>Fix:
	Apply patch from https://bugs.ntp.org/3877




Home | Main Index | Thread Index | Old Index