NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

re: kern/54317: System hang during boot

>  I remembered that the graphics card was newer than 2010 and there's this warning:
>  > [     8.386333] radeon0: autoconfiguration error: error: radeon_vce: Can't load firmware "radeon/TAHITI_vce.bin"

[     7.565961] kern info: [drm] initializing kernel modesetting (PITCAIRN 0x1002:0x6818 0x1682:0x3252).

ah, "southern islands".

i have a card in this generation and we're out of luck until we
get a drm update.  the existing code only supports them in the
radeon driver, but much of the rest is broken in radeon vs
amdgpu driver -- Mesa complains (tries amdgpu style fail), and
i don't recall that Xvideo even works.

the newer drm code supports this card in amdgpu and i suspect
then it will be fine.  until then, this card will not work well.
(if our amdgpu code worked, newer tech cards might work, but 
this 1st generation GCN was poorly supported in our drm.)

>  So I tried disableing all radeon* and radeondrmkmsfb* and radeonfb*
> with userconf, but that didn't help.

what happened?  i assume vga attached instead, and whatever the
problem is remains, ie, probably not the gpu?

i would just keep disabling drivers -- there are a *lot* that
attach something -- and see if anything helps.


Home | Main Index | Thread Index | Old Index