NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: misc/53564: tmux: pagination/wordwrap misalingment

The following reply was made to PR misc/53564; it has been noted by GNATS.

From: Leonardo Taccari <>
Subject: Re: misc/53564: tmux: pagination/wordwrap misalingment
Date: Sun, 02 Sep 2018 23:15:44 +0200

 Hello Courtney,
 Courtney R. Spencer writes:
 > [...]
 >  On Sat, Sep 1, 2018 at 10:07 PM Courtney R. Spencer <
 > wrote:
 >  =
 >  > Thanks for looking into.
 >  > But tmux 2.4 in 8.0 base and pkgsrc tmux 2.6 exhibit the same behavio=
 >  > on my 8.0 system...
 >  >
 >  > This was not the case of base tmux 2.4 in 7.1.1.  I noticed the chang=
 e in behavior
 >  > almost immediately after upgrading with the base tmux.  I've tried bu=
 >  > pkgsrc tmux 2.6 with system curses and ncurses; I've tried importing =
 >  > screen.terminfo as well before having any info.
 >  >
 >  =
 >  Correction, 7.1.1 had tmux "1.9a" in base which works fine.
 >  =
 Thanks for also checking that and good!
 >  I didn't realize how much I use copy/paste until copying around ssh
 >  keys with cat(1)
 >  resulted in some unexpected behavior.  Then I tried copying ps output
 >  and saw the same
 >  behavior for long lines.
 >  =
 >  But still, I validated tmux 2.6 in pkgsrc has the referenced diff
 >  applied, and still exhibits the
 >  same behavior.
 >  =
 Mmh, probably you have already done that but just to double-check
 that...  Can you please start tmux-2.6 via something like (the `-L'
 will hopefully make a difference):
  % /usr/pkg/bin/tmux -L tmux-2.6
 If `-L' and/or `-S' option is not used and there are tmux sessions
 present I think that the problem can still manifest because the
 server running can be the (problematic) tmux-2.4 one.^[0]
 I hope this will make a difference!... If not, please also share the
 terminal used (xterm or similars).
 Thank you for the quick feedback!
 [0]: Just a side story but I think that I was bitten by that several
      times when trying to patch tmux, spent several minutes why
      the behaviour wasn't changed by the patch and then figured
      out that it was actually not really applied because there was
      an existent session and so the new code was not run! :)

Home | Main Index | Thread Index | Old Index