NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

toolchain/53471: non-reproducable debug information

>Number:         53471
>Category:       toolchain
>Synopsis:       non-reproducable debug information
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    toolchain-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jul 25 11:20:00 +0000 2018
>Originator:     Martin Husemann
>Release:        NetBSD 8.99.22
The NetBSD Foundation, Inc.
System: NetBSD 8.99.22 NetBSD 8.99.22 (GENERIC) #231: Mon Jul 16 10:05:40 CEST 2018 amd64
Architecture: x86_64
Machine: amd64

I tried to reproduce the official amd64 8.0 build locally.
This worked quite well, but one file has different debug

--- local/usr/libdata/debug/usr/X11R7/lib/modules/drivers/
+++ releng/usr/libdata/debug/usr/X11R7/lib/modules/drivers/
    readelf --wide --debug-dump=info {}
 @@ -7040,15 +7040,15 @@
   <3><3bfd>: Abbrev Number: 0
   <2><3bfe>: Abbrev Number: 0
   <1><3bff>: Abbrev Number: 32 (DW_TAG_array_type)
      <3c00>   DW_AT_type        : <0x1e2>
      <3c04>   DW_AT_sibling     : <0x3c0f>
   <2><3c08>: Abbrev Number: 33 (DW_TAG_subrange_type)
      <3c09>   DW_AT_type        : <0x13a>
 -    <3c0d>   DW_AT_upper_bound : 55
 +    <3c0d>   DW_AT_upper_bound : 65
   <2><3c0e>: Abbrev Number: 0
   <1><3c0f>: Abbrev Number: 70 (DW_TAG_variable)
      <3c10>   DW_AT_name        : (indirect string, offset: 0x1e31): VMWAREBuildStr
      <3c14>   DW_AT_decl_file   : 1
      <3c15>   DW_AT_decl_line   : 91
      <3c16>   DW_AT_type        : <0x3c1a>
   <1><3c1a>: Abbrev Number: 15 (DW_TAG_const_type)

This kinda sounds like a binutils bug to me.

Checkout netbsd-8-0-RELEASE, try to build an amd64 release
with MKREPRO=yes and compare results to the official

The actual command I used was:

/work/src-8/ -m amd64 -B 201807172014Z -D /work/hosts-80r -T /work/tools-80r -R /work/rel-80r -M /work/obj-80r -U -X /work/xsrc-8 -P -x -N0 -V TMPDIR=/var/shm/btmp -V MAKECONF=/tmp/make.conf -V MKDEBUG=yes -j12 release iso-image install-image

(and MAKECONF was an empty file)


Home | Main Index | Thread Index | Old Index