NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bin/53443: named and dig not working with HMAC-SHA512 TSIG

>Number:         53443
>Category:       bin
>Synopsis:       named and dig not working with HMAC-SHA512 TSIG
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jul 11 18:00:00 +0000 2018
>Release:        NetBSD 7.0.2
System: NetBSD 7.0.2 NetBSD 7.0.2 (XEN3_DOMU.201610210724Z) amd64
Architecture: x86_64
Machine: amd64
Has named.conf setup to use TSIG. The algorithm is HMAC-SHA512.
My zone transfers failed with "tsig indicates error"
(or if IPv6 with "operation canceled").
Also using dig with -y failed and the pseudo section showed BADSIG.
This is NetBSD's base BIND which is 9.10.4-P3
I installed bind-9.10.7 withj pkgin and same named.conf worked for
tsig and my zone transfer and same /usr/pkg/bin/dig -y  worked for me.
I dont' know if the problem is with HMAC-SHA512 specifically. I didn't test
further, but at least I know the package works and base install doesn't.


Home | Main Index | Thread Index | Old Index