NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-amd64/51953: NetBSD do not boot on EFI

>Number:         51953
>Category:       port-amd64
>Synopsis:       NetBSD do not boot on EFI
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    port-amd64-maintainer
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Sun Feb 05 23:35:00 +0000 2017
>Originator:     Przemysław Pintal
>Release:        7.99.59
NetBSD/x86 EFI Boot (x64), Revision 1.0 (from NetBSD 7.99.59)
Memory: 640/2344900 k

This is output of version command from boot prompt (option in bootloader menu).
Hello! I downloaded "NetBSD-7.99.59-amd64-uefi-install.img.gz" from and I can boot to bootloader. No matter which option I will choose, I have always some numbers, like progress of loading image or mounting initial ramdisk, and when it finishes loading, then screen is black with only one symbol: "_". After some time nothing changes.

My spec (this is laptop):


I'm booting from pendrive.

But I can enter to boot prompt. I tried to manually boot with: boot hd0b:netbsd, boot hd0b, boot. These commands work, but this issue still occurs. With ls I have list of folders from image. dev normally detects disks.

I tried command efivars. There is some list with guid, variable name and value - I grabbed screen picture with smartphone. Every time use of this command results in a different outcome - random list of variables. In one case does not display anything. Always end in this way: GetNextVariableName failed: Invalid parameter

Best Regards!

Przemysław Pintal

Try to boot on computer with EFI.

Home | Main Index | Thread Index | Old Index