NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/49831: kernel panic on close of ucom tty

The following reply was made to PR kern/49831; it has been noted by GNATS.

From: Iain Hibbert <>
To: Nick Hudson <>,
Subject: Re: kern/49831: kernel panic on close of ucom tty
Date: Sat, 25 Jun 2016 09:13:51 +0100 (BST)

 On Thu, 9 Jun 2016, Nick Hudson wrote:
 > On 05/08/16 20:53, Iain Hibbert wrote:
 > > On Sun, 8 May 2016, Nick Hudson wrote:
 > > 
 > > > Hi,
 > > > 
 > > > I have a fix that I've been working on
 > > > 
 > > > Can you test it if I send the diff through?
 > > 
 > > I got a new laptop (upgraded to T61p) and have only just installed amd64
 > > (I just slipped the old HD in and ran i386 for a while).. I'll see if I
 > > can copy an i386 live-image to a USB stick and boot from that on my T60
 > > (which has no disk now). Can't do it tonight though, perhaps this week ..
 > > please send patch at least?
 > sorry, for the delay. I've added the diffs to my branch and created i386/amd64
 > GENERIC kernels
 > for you.  They're here:
 Sorry for the delay on my part too!
 as said, I'm on a new laptop - I still have the old one in storage but no 
 disk at this time, and my USB stick is defunct I need another
 anyway, I tried this on the T61p running a standard NetBSD amd64 7.99.29 
 kernel and had a slightly different process but similar result. I plugged 
 the serial/parallel adapter in and it attached as normal
 uhub7 at uhub4 port 3: vendor 0517 product 0606, class 9/0, rev 2.00/7.02, addr 2
 uhub7: single transaction translator
 uhub7: 2 ports with 0 removable, self powered
 ulpt0 at uhub7 port 1 configuration 1 interface 0
 ulpt0: Prolific Technology Inc. IEEE-1284 Controller, rev 1.00/2.02, addr 3, iclass 7/1
 ulpt0: using bi-directional mode
 uplcom0 at uhub7 port 2
 uplcom0: Prolific Technology Inc. USB-Serial Controller, rev 1.10/3.00, addr 4
 ucom0 at uplcom0
 I then connected to the com port (nothing plugged in) with 'cu -l 
 /dev/ttyU0' and disconnected ok .. tried again, and the system froze I was 
 unable to see anything else -- bit of blind typing and I managed to 
 reboot, all I could get from the message buffer was
 ulpt0: detached
 ulpt0: at uhub7 port 1 (addr 3) disconnected
 panic: kernel diagnostic assertion "xfer->ux_state == XFER_BUSY" failed: file "/var/cvs/NetBSD-current/src/sys/dev/usb/ehci.c", line 1573 xfer 0xfffffe8107880960 state 158
 fatal breakpoint trap in supervisor mode
 trap type 1 code 0 rip ffffffff80114ae5 cs 8 rflags 246 cr2 75b607107068 ilevel 0 rsp fffffe8040defb00
 curlwp 0xfffffe81078865a0 pid 0.55 lowest kstack 0xfffffe8040dec2c0
 so anyway, I booted your amd64 kernel and I have a slightly different 
 problem with that, because the nouveau driver doesn't quite work on this 
 laptop so the screen is unreadable (though I can see green/white blobs so 
 I know its working ok inside :)
 anyway, the same process (although in single-user mode) and no panic. So, 
 I'd say that something is good with your code!

Home | Main Index | Thread Index | Old Index