NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

toolchain/51147: Segmentation fault with on OpenBSD current (trying rump)

>Number:         51147
>Category:       toolchain
>Synopsis:       Segmentation fault with on OpenBSD current (trying rump)
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    toolchain-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue May 17 12:55:00 +0000 2016
>Originator:     Tomá? Bod?ár
>Release:        HEAD/201605170140Z
Tieto Czech s.r.o.
$ uname -a
OpenBSD fqdn 6.0 GENERIC.MP#2057 amd64


trying to get running inside OpenBSD (in VirtualBox 5 on Windows 7 64bit). However is not working with either default gcc or newer one from packages. Antti pointed this one out which was exactly what I get.

So instead I followed his advice from here , downloaded sets from{share,gnu,sys,}src.tgz and tried build, first with no CC defined (default gcc), then with CC=egcc (from packages). But always getting same error which you can see here

Tried that already 6 times and still exactly same result.

$ gcc -v
Reading specs from /usr/lib/gcc-lib/amd64-unknown-openbsd6.0/4.2.1/specs
Target: amd64-unknown-openbsd6.0
Configured with: OpenBSD/amd64 system compiler
Thread model: posix
gcc version 4.2.1 20070719

$ egcc -v
Using built-in specs.
Target: x86_64-unknown-openbsd6.0
Configured with: /usr/obj/ports/gcc-4.9.3/gcc-4.9.3/configure --enable-libgcj --without-jar --verbose --program-transform-name='s,^,e,' --disable-nls --with-system-zlib --disable-libmudflap --disable-libgomp --disable-tls --with-as=/usr/bin/as --with-ld=/usr/bin/ld --with-gnu-ld --with-gnu-as --enable-threads=posix --enable-wchar_t --with-gmp=/usr/local --enable-languages=c,c++,fortran,objc,java,ada --disable-libstdcxx-pch --enable-cpp --prefix=/usr/local --sysconfdir=/etc --mandir=/usr/local/man --infodir=/usr/local/info --localstatedir=/var --disable-silent-rules --disable-gtk-doc
Thread model: posix
gcc version 4.9.3 (GCC)

Right now not sure if it is problem in src-netbsd, OpenBSD itself, cooperation of those two, load on VM and/or host or fail

Not right now to me.

Home | Main Index | Thread Index | Old Index