NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-i386/48621: openvpn and openssl not getting along?

>Number:         48621
>Category:       port-i386
>Synopsis:       openvpn and openssl not getting along?
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    port-i386-maintainer
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Thu Feb 27 04:50:00 +0000 2014
>Originator:     Nickolas Nolan
NetBSD ovpn 6.1.2 NetBSD 6.1.2 (GENERIC) i386

I think this is related more to openssl than openvpn, but they're both giving 
me several separate issues that are probably related.
I got them from pkg_add using the ftp above.

This is definitely a support request, not a bug.

1. OpenVPN didn't come with an easy-rsa section. I've been trying to use the 
easy-rsa scripts directly off of the OpenVPN website.

2. I can't seem to get a good working example going from 
/usr/pkg/share/examples/openssl/openssl.cnf, so i'm getting various errors 
trying to sign my certs with a CA.

would someone mind pointing me to a better working openssl.cnf? 

Thank you.
I wanted to sysupgrade to 6.1.3 to see if it was worked out, but I ran across 
PR install/48515
pkg_add openvpn openssl

use easy-rsa from

try to build certs, ca etc using easy-rsa (or manually with openssl ca)

Home | Main Index | Thread Index | Old Index