NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: toolchain/47188: MKTOOLS=no broken

> Please try the attached patch.  It does the following:

Thanks, 1st attempt to build tools with:

mkdir -p /var/obj/NetBSD/current/amd64/obj \
/var/obj/NetBSD/current/amd64/destdir \
 /var/obj/NetBSD/current/amd64/release \
TOOLDIR=/var/obj/NetBSD/current/tools/NetBSD-6.99.15-x86_64 MKTOOLS=
sh -x ./ -j 3 -m amd64 -O /var/obj/NetBSD/current/amd64/obj \
-D/var/obj/NetBSD/current/amd64/destdir \
-R /var/obj/NetBSD/current/amd64/release tools

got as far as:

/var/obj/NetBSD/current/tools/NetBSD-6.99.15-x86_64/bin/nbhost-mkdep -d
-f .depend -s .lo\ .ln
sh: /var/obj/NetBSD/current/tools/NetBSD-6.99.15-x86_64/bin/nbhost-mkdep: not 
*** [.depend] Error code 127
nbmake: stopped in /h/NetBSD/current/src/tools/host-mkdep
1 error

I blew it all away and tried without -j3 - same result.

I'm not sure how 'make depend' should work in that dir - since its the
tool that 'make depend' relies on. does not look like does any tests for !target etc, so one
cannot just create a dummy target - which suggests I'm missing

Home | Main Index | Thread Index | Old Index