NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/46929: SD micro in SD adapter does not work

>Number:         46929
>Category:       kern
>Synopsis:       SD micro in SD adapter does not work
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Sep 08 23:05:00 +0000 2012
>Release:        NetBSD 6.0_RC1
System: NetBSD gift 6.0_RC1 NetBSD 6.0_RC1 (GIFT) #6: Sat Sep  1 04:44:23 UTC
2012  root@gift:/usr/obj/sys/arch/amd64/compile/GIFT amd64
Architecture: amd64
Machine: amd64

This is an SD micro card in an SD adapter:

umass0 at uhub3 port 2 configuration 1 interface 0
umass0: Generic Mass Storage Device, rev 2.00/1.00, addr 2
umass0: using SCSI over Bulk-Only
scsibus0 at umass0: 2 targets, 1 lun per target
sd0 at scsibus0 target 0 lun 0: <Multiple, Card  Reader, 1.00> disk removable
sd0: drive offline
sd0(umass0:0:0:0):  Check Condition on CDB: 0x00 00 00 00 00 00
    SENSE KEY:  Not Ready
 COMMAND INFO:  11162945 (0xaa5541)
     ASC/ASCQ:  Medium Not Present

sd0: unable to open device, error = 19

Now, you might say the adapter is broke. Tested three or four adapters with
different SD micro cards to be sure. The SD micro cards were for sure working.
Although some of the SD adapters were questionable, some of them were still
known to work.

I thought this may have been a problem with the device itself, which is why i
didn't bother reporting it until i found a normal SD card. The SD card works
fine. sd0 attaches and i can read/write to the drive, so it's not the device.

Dmesg is in PR pkg/46919.

Put an SD micro card in an SD adapter. Insert it into SD slot. `dmesg | tail`

Home | Main Index | Thread Index | Old Index