NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

toolchain/46827: Cannot build the kernel, even Generic.

>Number:         46827
>Category:       toolchain
>Synopsis:       Cannot build the kernel, even Generic.
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    toolchain-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Aug 23 11:50:00 +0000 2012
>Originator:     RIfat Mahmud
>Release:        5.1 source cd ISO
Linux rifat-K40IJ 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 
i686 i686 i386 GNU/Linux

I downloaded the NetBSD source, ran './ -m i386 tools', as my plan is 
to run the NetBSD on QEMU and Virtualbox. Build log is huge, it is quite 
impossible for me to find out any unfinished build, but I think building tools 
is successful, because it ends without any error.
Then I tried '..../nbconfig .../GENERIC', it says, cannot configure GENERIC. I 
tried new './ -m i386 kernel=GENERIC', it shows error, and ends with 

I have libbsd-dev, libncurses-dev, pmake, etc. installed(As mentioned in 

Have a machine of my kind. I'm running Linux Mint 13 Maya on ASUS K40IJ Laptop, 
2 GB RAM, CPU Pentium T4300.gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3

Extract all the sources in /home/'User'/Documents/NetBSD.

Run './ -m i386 tools' or './ -m i386 -O obj tools'

Should end without error.

Then run '/ -m i386 kernel=GENERIC'

It'll not end successfully and gives this error(involving 

I reproduced this around 15 time.

Home | Main Index | Thread Index | Old Index